summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-11-05 11:46:26 (GMT)
committerBrad King <brad.king@kitware.com>2013-01-10 14:54:52 (GMT)
commit3581b96caa1d7bd6c02e85baf72ce28b5128e5e7 (patch)
tree048d95ad2d6d1071982b1a35c6ce87d35831cc81 /Tests/RunCMake/CMakeLists.txt
parent042ecf0471be84ce6c3e6c32dae526fdbd9a3a14 (diff)
downloadCMake-3581b96caa1d7bd6c02e85baf72ce28b5128e5e7.zip
CMake-3581b96caa1d7bd6c02e85baf72ce28b5128e5e7.tar.gz
CMake-3581b96caa1d7bd6c02e85baf72ce28b5128e5e7.tar.bz2
Process the INTERFACE_PIC property from linked dependencies
This allows a dependee to inform a target that it should have its POSITION_INDEPENDENT_CODE property set to ON, or OFF. The value of the POSITION_INDEPENDENT_CODE property, if set, must be consistent with any INTERFACE_POSITION_INDEPENDENT_CODE properties on dependees. Add a test covering the consistency checks on platforms where they run.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index fec64b5..9b133b2 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -50,6 +50,9 @@ add_RunCMake_test(GeneratorExpression)
add_RunCMake_test(TargetPropertyGeneratorExpressions)
add_RunCMake_test(Languages)
add_RunCMake_test(ObjectLibrary)
+if(NOT WIN32)
+ add_RunCMake_test(PositionIndependentCode)
+endif()
add_RunCMake_test(build_command)
add_RunCMake_test(find_package)