summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-03-12 22:20:01 (GMT)
committerBrad King <brad.king@kitware.com>2013-03-12 22:20:44 (GMT)
commitd90f49b8948c3047cb0839ce505f796952dbd880 (patch)
tree616a2b74cad6d1690ad0809eb87d6e49ea7d6979 /Tests/RunCMake/CMakeLists.txt
parent2e1c2bd2dd97e426944d6ac18e4073ec26ddf64c (diff)
downloadCMake-d90f49b8948c3047cb0839ce505f796952dbd880.zip
CMake-d90f49b8948c3047cb0839ce505f796952dbd880.tar.gz
CMake-d90f49b8948c3047cb0839ce505f796952dbd880.tar.bz2
CTest: Fail early without PROJECT_BINARY_DIR (#14005)
Do not use PROJECT_BINARY_DIR before it is defined. If it is not defined when needed, fail with an error message suggesting that the project() command be invoked first.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index dba772d..4b4bd31 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -52,6 +52,7 @@ if(XCODE_VERSION AND "${XCODE_VERSION}" VERSION_LESS 3)
endif()
add_RunCMake_test(CMP0019)
+add_RunCMake_test(CTest)
if(UNIX AND "${CMAKE_TEST_GENERATOR}" MATCHES "Unix Makefiles")
add_RunCMake_test(CompilerChange)
endif()