summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-12-03 12:26:51 (GMT)
committerStephen Kelly <steveire@gmail.com>2013-12-08 06:03:29 (GMT)
commit77f3772784152701ff0eee5e4a19177996c03c0e (patch)
treec20abe0601fc037887e11b7c2ef6f20c21596801 /Tests/RunCMake/CMakeLists.txt
parent2e60b5fcf7929232c2e731f21e1ab9a889949fa3 (diff)
downloadCMake-77f3772784152701ff0eee5e4a19177996c03c0e.zip
CMake-77f3772784152701ff0eee5e4a19177996c03c0e.tar.gz
CMake-77f3772784152701ff0eee5e4a19177996c03c0e.tar.bz2
cmTarget: Require a compatible INTERFACE_AUTOUIC_OPTIONS from dependencies.
Revert the origin-tracking infrastructure from commit 98093c45 (QtAutoUic: Add INTERFACE_AUTOUIC_OPTIONS target property., 2013-11-20). Use the compatibility-tracking for compatible strings instead. If two different dependencies require different AUTOUIC_OPTIONS, cmake will now appropriately issue an error.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 593921f..96b0543 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -94,6 +94,9 @@ if(NOT WIN32)
add_RunCMake_test(VisibilityPreset)
endif()
endif()
+if (QT4_FOUND)
+ set(CompatibleInterface_ARGS -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
+endif()
add_RunCMake_test(CompatibleInterface)
add_RunCMake_test(Syntax)