summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-10-29 00:05:13 (GMT)
committerBrad King <brad.king@kitware.com>2022-10-30 12:29:55 (GMT)
commit2e5af30ce0181b6652fb6f3a90d2292b065dee8d (patch)
treeba16e19f6925460023b68ce97d6949684b083067 /Tests/RunCMake/CMakeLists.txt
parente1c16791481f1741d65cb98878d8171307422513 (diff)
downloadCMake-2e5af30ce0181b6652fb6f3a90d2292b065dee8d.zip
CMake-2e5af30ce0181b6652fb6f3a90d2292b065dee8d.tar.gz
CMake-2e5af30ce0181b6652fb6f3a90d2292b065dee8d.tar.bz2
Ninja: Match showIncludes dependencies using console output code page
Generalize the fix from commit 37a279f8d1 (Ninja: Write msvc_deps_prefix as UTF-8 when console codepage is UTF-8, 2020-07-31, v3.19.0-rc1~349^2). `cl /showIncludes` output is encoded using the console output code page, so this is the byte sequence that Ninja must use to match its lines. Fixes: #24068
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 6c5ab7f..3038ed8 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -197,6 +197,10 @@ if(CMAKE_GENERATOR MATCHES "Ninja")
${ninja_qt_args}
)
endif()
+ if(WIN32)
+ add_executable(showIncludes showIncludes.c)
+ list(APPEND Ninja_ARGS -DshowIncludes=$<TARGET_FILE:showIncludes>)
+ endif()
add_RunCMake_test(Ninja)
set(NinjaMultiConfig_ARGS
-DCYGWIN=${CYGWIN} -DMSYS=${MSYS}