summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorKasper Laudrup <you@example.com>2022-04-01 18:18:33 (GMT)
committerCraig Scott <craig.scott@crascit.com>2022-05-04 23:01:54 (GMT)
commita283e58b51e55bc843c8d341bf0f8bc91f2f9ef1 (patch)
tree1044c82c2bae6115ebe0fc32f6b6cfac77312f12 /Tests/RunCMake/CMakeLists.txt
parente0dbca93aae6b01f8b239d346a0bc99d2ca2473e (diff)
downloadCMake-a283e58b51e55bc843c8d341bf0f8bc91f2f9ef1.zip
CMake-a283e58b51e55bc843c8d341bf0f8bc91f2f9ef1.tar.gz
CMake-a283e58b51e55bc843c8d341bf0f8bc91f2f9ef1.tar.bz2
ExternalProject: Add DOWNLOAD_EXTRACT_TIMESTAMP option and policy
Add the option to keep the current filestamps when extracting an archive in ExternalProject_Add. Enabling this option makes the behavior consistent with how ExternalProject_Add is used when checking out code from revision control instead of an archive. Fixes: #22746
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index c2677a0..515c6d8 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -149,6 +149,7 @@ if("${CMAKE_C_COMPILER_ID}" STREQUAL "LCC" OR
endif()
add_RunCMake_test(CMP0132)
+add_RunCMake_test(CMP0135)
# The test for Policy 65 requires the use of the
# CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS variable, which both the VS and Xcode