summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2019-11-07 18:10:46 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-11-07 18:10:57 (GMT)
commitbea26f5aa0e1b98dea9d87ba2444c0901842f97c (patch)
treea95073df644c93e9b2a887906ed21e900b9857c4 /Tests/RunCMake/CMakeLists.txt
parent74569996e8fe798386cca2d4241acea0644f6275 (diff)
parent016601e5e6f152403306c12997534aadd4287d38 (diff)
downloadCMake-bea26f5aa0e1b98dea9d87ba2444c0901842f97c.zip
CMake-bea26f5aa0e1b98dea9d87ba2444c0901842f97c.tar.gz
CMake-bea26f5aa0e1b98dea9d87ba2444c0901842f97c.tar.bz2
Merge topic 'ctest-resource-groups'
016601e5e6 Merge branch 'backport-ctest-resource-groups' c1435d9812 Help: Fix error in resource allocation example eb9d945f14 CTest: Rename hardware -> resources for RunCMake tests c544cb6698 CTest: Rename hardware -> resources for source code 6ce27d3a2e cmCTestMultiProcessHandler: Rename resource locking functions a7c1e15cc4 CTest: Rename hardware -> resources for CMake variables, command options 73a40b19ff CTest: Rename "Processes" lexer to "ResourceGroups" af9ed543b0 CTest: Rename PROCESSES test property to RESOURCE_GROUPS Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !3994
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt24
1 files changed, 12 insertions, 12 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 4490751..0a090a8 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -339,7 +339,7 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
-# cthwalloc links against CMakeLib and CTestLib, which means it can't be built
+# ctresalloc links against CMakeLib and CTestLib, which means it can't be built
# if CMake_TEST_EXTERNAL_CMAKE is activated (the compiler might be different.)
# So, it has to be provided in the original build tree.
if(CMake_TEST_EXTERNAL_CMAKE)
@@ -347,7 +347,7 @@ if(CMake_TEST_EXTERNAL_CMAKE)
if(NOT CMAKE_VERSION VERSION_LESS 3.12)
set(no_package_root_path NO_PACKAGE_ROOT_PATH)
endif()
- find_program(cthwalloc cthwalloc PATHS ${CMake_TEST_EXTERNAL_CMAKE}
+ find_program(ctresalloc ctresalloc PATHS ${CMake_TEST_EXTERNAL_CMAKE}
NO_DEFAULT_PATH
${no_package_root_path}
NO_CMAKE_PATH
@@ -356,25 +356,25 @@ if(CMake_TEST_EXTERNAL_CMAKE)
NO_CMAKE_SYSTEM_PATH
NO_CMAKE_FIND_ROOT_PATH
)
- if(cthwalloc)
- add_executable(cthwalloc IMPORTED)
- set_property(TARGET cthwalloc PROPERTY IMPORTED_LOCATION ${cthwalloc})
+ if(ctresalloc)
+ add_executable(ctresalloc IMPORTED)
+ set_property(TARGET ctresalloc PROPERTY IMPORTED_LOCATION ${ctresalloc})
endif()
else()
- add_executable(cthwalloc CTestHardwareAllocation/cthwalloc.cxx)
- target_link_libraries(cthwalloc CTestLib)
- target_include_directories(cthwalloc PRIVATE
+ add_executable(ctresalloc CTestResourceAllocation/ctresalloc.cxx)
+ target_link_libraries(ctresalloc CTestLib)
+ target_include_directories(ctresalloc PRIVATE
${CMake_BINARY_DIR}/Source
${CMake_SOURCE_DIR}/Source
${CMake_SOURCE_DIR}/Source/CTest
)
- set_property(TARGET cthwalloc PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMake_BIN_DIR})
+ set_property(TARGET ctresalloc PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMake_BIN_DIR})
endif()
-if(TARGET cthwalloc)
- add_RunCMake_test(CTestHardwareAllocation -DCTHWALLOC_COMMAND=$<TARGET_FILE:cthwalloc>)
+if(TARGET ctresalloc)
+ add_RunCMake_test(CTestResourceAllocation -DCTRESALLOC_COMMAND=$<TARGET_FILE:ctresalloc>)
else()
- message(WARNING "Could not find or build cthwalloc")
+ message(WARNING "Could not find or build ctresalloc")
endif()
find_package(Qt4 QUIET)