summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2018-06-11 19:33:23 (GMT)
committerKyle Edwards <kyle.edwards@kitware.com>2018-07-02 13:51:02 (GMT)
commit2ef966bc77e9efd036747ee9d6977e2f2c7e024d (patch)
tree3823d55e5706dfee4aa903766956df4246b8de97 /Tests/RunCMake/CMakeLists.txt
parent80914d88da3e5c997158fd3cc703a39b6673f780 (diff)
downloadCMake-2ef966bc77e9efd036747ee9d6977e2f2c7e024d.zip
CMake-2ef966bc77e9efd036747ee9d6977e2f2c7e024d.tar.gz
CMake-2ef966bc77e9efd036747ee9d6977e2f2c7e024d.tar.bz2
Testing: Add test for CPack External generator
This test case ensures that the CPack External generator produces the proper .json file, and also ensures that the version negotation with CPACK_EXT_REQUESTED_VERSIONS works properly.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index daf3940..dcc7c98 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -422,7 +422,7 @@ if("${CMAKE_GENERATOR}" MATCHES "Make|Ninja")
add_RunCMake_test(ctest_labels_for_subprojects)
endif()
-add_RunCMake_test_group(CPack "DEB;RPM;7Z;TBZ2;TGZ;TXZ;TZ;ZIP;STGZ")
+add_RunCMake_test_group(CPack "DEB;RPM;7Z;TBZ2;TGZ;TXZ;TZ;ZIP;STGZ;Ext")
# add a test to make sure symbols are exported from a shared library
# for MSVC compilers CMAKE_WINDOWS_EXPORT_ALL_SYMBOLS property is used
add_RunCMake_test(AutoExportDll)