summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-06-09 16:11:49 (GMT)
committerBrad King <brad.king@kitware.com>2022-06-09 16:24:33 (GMT)
commit7d73e88d3a7490cf1047369da8292a57c0b60bce (patch)
treec2d19d741e502df1f4bf064b28037287085cd35d /Tests/RunCMake/CMakeLists.txt
parent84da420a29155e206cef48fc7b05bf818539feb6 (diff)
downloadCMake-7d73e88d3a7490cf1047369da8292a57c0b60bce.zip
CMake-7d73e88d3a7490cf1047369da8292a57c0b60bce.tar.gz
CMake-7d73e88d3a7490cf1047369da8292a57c0b60bce.tar.bz2
MSVC: Revert "Default to -ZI instead of /Zi for x86 and x64"
Revert commit 5fcadc481e (MSVC: Default to -ZI instead of /Zi for x86 and x64, 2022-05-24). The `-ZI` flag is incompatible with the `-GL` flag used for IPO, and so is not an unconditionally better default. Revert the change pending future design of a first-class setting for MSVC debug info format that can be automatically reconciled with IPO settings. That commit introduced policy CMP0138, but we already have later policy numbers used too. Leave placeholder text to avoid policy renumbering. Issue: #23607, #10189
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 4b00212..5325a3a 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -355,9 +355,6 @@ if(MSVC)
add_RunCMake_test(MSVCRuntimeLibrary)
add_RunCMake_test(MSVCRuntimeTypeInfo)
add_RunCMake_test(MSVCWarningFlags)
- if (CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
- add_RunCMake_test(MSVCDebugInformationFormat)
- endif()
endif()
if(XCODE_VERSION)
set(ObjectLibrary_ARGS -DXCODE_VERSION=${XCODE_VERSION})