summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2018-09-12 17:33:04 (GMT)
committerKyle Edwards <kyle.edwards@kitware.com>2018-09-19 15:23:08 (GMT)
commiteedd91ab085d551d7953f8bb6fe01fd5540af004 (patch)
tree06c48354c007001780a079d2a6b86fd7bdd822bc /Tests/RunCMake/CMakeLists.txt
parentfd28ea35ca5f62e52d030288bf60ca6fe769cb96 (diff)
downloadCMake-eedd91ab085d551d7953f8bb6fe01fd5540af004.zip
CMake-eedd91ab085d551d7953f8bb6fe01fd5540af004.tar.gz
CMake-eedd91ab085d551d7953f8bb6fe01fd5540af004.tar.bz2
BundleUtilities: Disallow inclusion at configure time
This commit adds a new CMake policy, CMP0080, which prohibits the inclusion of BundleUtilities at configure time. The old behavior is to allow the inclusion.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index c6c90d0..69cb5b7 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -251,6 +251,7 @@ add_RunCMake_test(separate_arguments)
add_RunCMake_test(set_property)
add_RunCMake_test(string)
add_RunCMake_test(test_include_dirs)
+add_RunCMake_test(BundleUtilities)
function(add_RunCMake_test_try_compile)
if(CMAKE_VERSION VERSION_LESS 3.9.20170907 AND "x${CMAKE_CXX_COMPILER_ID}" STREQUAL "xMSVC")