summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-08-06 14:29:17 (GMT)
committerKitware Robot <kwrobot@kitware.com>2020-08-06 14:31:23 (GMT)
commit030aa9dc30f5be3eeb0e4d632eb39daeb1089d14 (patch)
treece0cc35d43b3d386242a8b704aa1f061df8514f2 /Tests/RunCMake/CMakeLists.txt
parent716dacc36aede2fdad016daee0ee30241ff88fe6 (diff)
parent9a9ed4b9d3f9658fa0615bb3cef601c5d396bf3b (diff)
downloadCMake-030aa9dc30f5be3eeb0e4d632eb39daeb1089d14.zip
CMake-030aa9dc30f5be3eeb0e4d632eb39daeb1089d14.tar.gz
CMake-030aa9dc30f5be3eeb0e4d632eb39daeb1089d14.tar.bz2
Merge topic 'automoc_timestamp_deps'
9a9ed4b9d3 Merge branch 'backport-3.17-automoc_timestamp_deps' 7445c9a58a AutoGen: Add test to check for correct AutoMoc dependencies a79056bb02 AutoGen: Fix over-specified direct dependencies of custom command Acked-by: Kitware Robot <kwrobot@kitware.com> Acked-by: Aleix <aleixpol@kde.org> Merge-request: !5085
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 4d2a53c..294e252 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -142,6 +142,9 @@ if(CMAKE_GENERATOR MATCHES "Ninja")
if(CMAKE_Fortran_COMPILER)
list(APPEND Ninja_ARGS -DTEST_Fortran=1)
endif()
+ if(CMake_TEST_Qt5 AND Qt5Core_FOUND)
+ list(APPEND Ninja_ARGS -DCMake_TEST_Qt5=1 -DCMAKE_TEST_Qt5Core_Version=${Qt5Core_VERSION})
+ endif()
add_RunCMake_test(Ninja)
set(NinjaMultiConfig_ARGS
-DCYGWIN=${CYGWIN}