summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@crascit.com>2022-04-28 13:00:19 (GMT)
committerCraig Scott <craig.scott@crascit.com>2022-05-03 06:48:11 (GMT)
commit29e31e2825a2cd5099b8abe66f4816919cec934a (patch)
treea1590254fba9ed2a4e5e80b6725fc3f9795ac269 /Tests/RunCMake/CMakeLists.txt
parent1d82670bd4daff26d0d0169820b289bc401f4943 (diff)
downloadCMake-29e31e2825a2cd5099b8abe66f4816919cec934a.zip
CMake-29e31e2825a2cd5099b8abe66f4816919cec934a.tar.gz
CMake-29e31e2825a2cd5099b8abe66f4816919cec934a.tar.bz2
Packages: Integrate FetchContent and find_package()
Allow FetchContent_MakeAvailable() to try a call to find_package() first, or redirect a find_package() call to FetchContent_MakeAvailable(). The user can set variables to control which of these are allowed or tried by default. Fixes: #21687
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index c2677a0..325ec2f 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -784,6 +784,7 @@ if(CMake_TEST_RunCMake_ExternalProject_DOWNLOAD_SERVER_TIMEOUT)
endif()
add_RunCMake_test(ExternalProject)
add_RunCMake_test(FetchContent)
+add_RunCMake_test(FetchContent_find_package)
set(CTestCommandLine_ARGS -DPython_EXECUTABLE=${Python_EXECUTABLE})
if(NOT CMake_TEST_EXTERNAL_CMAKE)
list(APPEND CTestCommandLine_ARGS -DTEST_AFFINITY=$<TARGET_FILE:testAffinity>)