summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-07-24 12:43:15 (GMT)
committerKitware Robot <kwrobot@kitware.com>2023-07-24 12:43:19 (GMT)
commit6194193a8a0a476539590aabbb27094d1aff136a (patch)
tree7b56eea1985a37978b58b64c35c53bf4c682d571 /Tests/RunCMake/CMakeLists.txt
parente61a51b5a247bec564cb48184b499d17386c0470 (diff)
parent6b5f2dbbfe453f9bafe46ee420e657735ff16fb0 (diff)
downloadCMake-6194193a8a0a476539590aabbb27094d1aff136a.zip
CMake-6194193a8a0a476539590aabbb27094d1aff136a.tar.gz
CMake-6194193a8a0a476539590aabbb27094d1aff136a.tar.bz2
Merge topic 'file-REAL_PATH-relative'
6b5f2dbbfe file(REAL_PATH): resolve symlinks before '..' components Acked-by: Kitware Robot <kwrobot@kitware.com> Acked-by: buildbot <buildbot@kitware.com> Merge-request: !8605
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index b278cef..608a4d9 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -165,6 +165,10 @@ if(GIT_EXECUTABLE)
add_RunCMake_test(CMP0150)
endif()
+if(NOT WIN32 OR CYGWIN)
+ add_RunCMake_test(CMP0152)
+endif()
+
# The test for Policy 65 requires the use of the
# CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS variable, which both the VS and Xcode
# generators ignore. The policy will have no effect on those generators.