summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-07-08 17:14:37 (GMT)
committerBrad King <brad.king@kitware.com>2015-07-08 17:23:16 (GMT)
commit7aa9e80e35f62ec5686d08b49ebe8b57cbc6cbc6 (patch)
treeedd7720bb6887c86b3dca7754662ab6335dba1db /Tests/RunCMake/CMakeLists.txt
parenta6916a6c6e397bda8b381f65dbfc59d3c52f8525 (diff)
downloadCMake-7aa9e80e35f62ec5686d08b49ebe8b57cbc6cbc6.zip
CMake-7aa9e80e35f62ec5686d08b49ebe8b57cbc6cbc6.tar.gz
CMake-7aa9e80e35f62ec5686d08b49ebe8b57cbc6cbc6.tar.bz2
set_property: Fix crash when setting LINK_LIBRARIES to nothing
We use a special dedicated structure to store the LINK_LIBRARIES target property. Do not try to construct a string from a NULL value. Instead leave the property structure empty when no value is given. Reported-by: Ghyslain Leclerc <ghleclerc@gmail.com>
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 592b5e4..81029cd 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -146,6 +146,7 @@ add_RunCMake_test(list)
add_RunCMake_test(message)
add_RunCMake_test(project)
add_RunCMake_test(return)
+add_RunCMake_test(set_property)
add_RunCMake_test(string)
add_RunCMake_test(try_compile)
add_RunCMake_test(try_run)