summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-11-19 14:51:57 (GMT)
committerKitware Robot <kwrobot@kitware.com>2018-11-19 14:52:07 (GMT)
commit95a735116f51285f78acb04d1bdc7863122fd94a (patch)
tree6da8840ecdca83c733a006e61ec05a40cd8ebd9b /Tests/RunCMake/CMakeLists.txt
parent61e3ceda21800949f1a4411f27efefcda789bd4d (diff)
parent86e8315482fd8f0bba85af6f4f8363ead6a0818d (diff)
downloadCMake-95a735116f51285f78acb04d1bdc7863122fd94a.zip
CMake-95a735116f51285f78acb04d1bdc7863122fd94a.tar.gz
CMake-95a735116f51285f78acb04d1bdc7863122fd94a.tar.bz2
Merge topic 'ctest-stdin'
86e8315482 CTest: Restore inheritance of stdin by test processes bdec3bd896 Tests: Teach RunCMake infrastructure to optionally provide stdin Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !2618
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 748314d..a4d829b 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -382,7 +382,8 @@ add_RunCMake_test(FetchContent)
if(NOT CMake_TEST_EXTERNAL_CMAKE)
set(CTestCommandLine_ARGS -DTEST_AFFINITY=$<TARGET_FILE:testAffinity>)
endif()
-add_RunCMake_test(CTestCommandLine)
+add_executable(print_stdin print_stdin.c)
+add_RunCMake_test(CTestCommandLine -DTEST_PRINT_STDIN=$<TARGET_FILE:print_stdin>)
add_RunCMake_test(CacheNewline)
# Only run this test on unix platforms that support
# symbolic links