summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2019-07-10 19:18:37 (GMT)
committerBrad King <brad.king@kitware.com>2019-10-02 13:33:54 (GMT)
commit3c8a5aad46ddbd1d0e4c02f09bd403601c6c94b3 (patch)
treeef75de24b04753eb077734c4d33e6387eebce448 /Tests/RunCMake/CMakeLists.txt
parent2d74e54661953a02efa155ffe8c093400e5389c3 (diff)
downloadCMake-3c8a5aad46ddbd1d0e4c02f09bd403601c6c94b3.zip
CMake-3c8a5aad46ddbd1d0e4c02f09bd403601c6c94b3.tar.gz
CMake-3c8a5aad46ddbd1d0e4c02f09bd403601c6c94b3.tar.bz2
Tests: Write tests for cthwalloc helper tool
This helper tool is sufficiently complex that it warrants having its own test suite.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 45c549b..0925c0e 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -367,6 +367,12 @@ else()
set_property(TARGET cthwalloc PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMake_BIN_DIR})
endif()
+if(TARGET cthwalloc)
+ add_RunCMake_test(CTestHardwareAllocation -DCTHWALLOC_COMMAND=$<TARGET_FILE:cthwalloc>)
+else()
+ message(WARNING "Could not find or build cthwalloc")
+endif()
+
find_package(Qt4 QUIET)
find_package(Qt5Core QUIET)
if (QT4_FOUND AND Qt5Core_FOUND AND NOT Qt5Core_VERSION VERSION_LESS 5.1.0)