summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2019-12-19 13:46:50 (GMT)
committerBen Boeckel <ben.boeckel@kitware.com>2020-01-20 20:49:29 (GMT)
commit3ec82b713e51711df0c70f539aea62fc16dd3060 (patch)
tree90ce909e0cdc41e5308c83da1c03af9bbfdf1e8a /Tests/RunCMake/CMakeLists.txt
parent701a5c60e059a53ebf458174253811167c1ae3fc (diff)
downloadCMake-3ec82b713e51711df0c70f539aea62fc16dd3060.zip
CMake-3ec82b713e51711df0c70f539aea62fc16dd3060.tar.gz
CMake-3ec82b713e51711df0c70f539aea62fc16dd3060.tar.bz2
cmMarkAsAdvancedCommand: ignore variables which don't exist in the cache
Fixes: #18331
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 0534974..95eeab8 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -115,6 +115,7 @@ if(CMAKE_SYSTEM_NAME MATCHES Darwin AND CMAKE_SHARED_LIBRARY_RUNTIME_C_FLAG)
endif()
add_RunCMake_test(CMP0069)
add_RunCMake_test(CMP0081)
+add_RunCMake_test(CMP0102)
# The test for Policy 65 requires the use of the
# CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS variable, which both the VS and Xcode