summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-10-31 13:43:54 (GMT)
committerKitware Robot <kwrobot@kitware.com>2022-10-31 13:44:12 (GMT)
commit5b23e3021b969638dd4ef168b362493f818ffe43 (patch)
tree491563b34b3aed8bc1b51d173fae93eeffc40f2f /Tests/RunCMake/CMakeLists.txt
parent17f63457628dd0d13f116d9a1b03c925012220b4 (diff)
parenta0d4e3bf347a1d995d064de19e14b71b87cbeeda (diff)
downloadCMake-5b23e3021b969638dd4ef168b362493f818ffe43.zip
CMake-5b23e3021b969638dd4ef168b362493f818ffe43.tar.gz
CMake-5b23e3021b969638dd4ef168b362493f818ffe43.tar.bz2
Merge topic 'ninja-showIncludes-encoding'
a0d4e3bf34 cmGeneratedFileStream: Drop unused WriteRaw method 2e5af30ce0 Ninja: Match showIncludes dependencies using console output code page e1c1679148 cm_codecvt: Add support for the Windows console output code page 328c15189d cmGeneratedFileStream: Add support for a temporary alternate encoding Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !7845
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 3f92829..280a21a 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -197,6 +197,10 @@ if(CMAKE_GENERATOR MATCHES "Ninja")
${ninja_qt_args}
)
endif()
+ if(WIN32)
+ add_executable(showIncludes showIncludes.c)
+ list(APPEND Ninja_ARGS -DshowIncludes=$<TARGET_FILE:showIncludes>)
+ endif()
add_RunCMake_test(Ninja)
set(NinjaMultiConfig_ARGS
-DCYGWIN=${CYGWIN} -DMSYS=${MSYS}