summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-12-15 21:35:54 (GMT)
committerBrad King <brad.king@kitware.com>2023-12-16 11:54:46 (GMT)
commit1dd4a9baff389f2f62142c38f76d6383290c6ed6 (patch)
tree9bef45eb02d9bda7e86055a31caada96fd14750a /Tests/RunCMake/CMakeLists.txt
parent3148db4533aa085c66f9727e17c6fe2960a0281c (diff)
downloadCMake-1dd4a9baff389f2f62142c38f76d6383290c6ed6.zip
CMake-1dd4a9baff389f2f62142c38f76d6383290c6ed6.tar.gz
CMake-1dd4a9baff389f2f62142c38f76d6383290c6ed6.tar.bz2
Tests: Cover generate_apple_platform_selection_file on all platforms
The test added by commit 37bc3400cd (CMakePackageConfigHelpers: Add generate_apple_platform_selection_file(), 2023-11-03) covers importing only on macOS, and is specific to the xcframework test case. Add a dedicated test for `generate_apple_platform_selection_file` that covers export and import on all platforms.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 7e1b0e4..dbcb94e 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -325,6 +325,13 @@ if(UNIX AND "${CMAKE_GENERATOR}" MATCHES "Unix Makefiles|Ninja")
add_RunCMake_test(Byproducts)
endif()
add_RunCMake_test(CMakeDependentOption)
+if(APPLE # Remove these conditions when the test has non-Apple cases
+ AND CMAKE_C_COMPILER_ID STREQUAL "AppleClang")
+ add_RunCMake_test(CMakePackage
+ -DCMake_TEST_XCODE_VERSION=${CMake_TEST_XCODE_VERSION}
+ -DCMAKE_C_COMPILER_ID=${CMAKE_C_COMPILER_ID}
+ )
+endif()
add_RunCMake_test(CMakeRoleGlobalProperty)
add_RunCMake_test(CMakeRelease -DCMake_TEST_JQ=${CMake_TEST_JQ})
if(CMAKE_GENERATOR MATCHES "Make|Ninja")