summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2024-05-15 15:52:27 (GMT)
committerKitware Robot <kwrobot@kitware.com>2024-05-15 15:52:44 (GMT)
commit96028ad95c21029a261d49de5a788f385e18c380 (patch)
treeffddd9a6e42f9a9eab0608f82322b50473de0cdf /Tests/RunCMake/CMakeLists.txt
parentea3e734f3f4a12cc74c01c543740535a9f2cfd16 (diff)
parent151a7d63dde41456f92ce27021ff9fc01faf21b7 (diff)
downloadCMake-96028ad95c21029a261d49de5a788f385e18c380.zip
CMake-96028ad95c21029a261d49de5a788f385e18c380.tar.gz
CMake-96028ad95c21029a261d49de5a788f385e18c380.tar.bz2
Merge topic 'test-execute_process-abnormal-exit'
151a7d63dd Tests: Cover execute_process with abnormal exit on all platforms Acked-by: Kitware Robot <kwrobot@kitware.com> Acked-by: buildbot <buildbot@kitware.com> Merge-request: !9518
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index ae5a161..76a68b4 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -516,10 +516,15 @@ set_property(TEST RunCMake.add_subdirectory APPEND PROPERTY LABELS "Fortran")
add_RunCMake_test(add_test -DPSEUDO_EMULATOR=$<TARGET_FILE:pseudo_emulator>)
add_RunCMake_test(build_command)
add_executable(exit_code exit_code.c)
+if(NOT CMAKE_C_COMPILER_ID MATCHES "OrangeC|Watcom"
+ AND NOT CMAKE_C_FLAGS MATCHES "-fsanitize=")
+ add_executable(exit_crash exit_crash.c)
+ set(EXIT_CRASH_EXE $<TARGET_FILE:exit_crash>)
+endif()
set(execute_process_ARGS
-DEXIT_CODE_EXE=$<TARGET_FILE:exit_code>
+ -DEXIT_CRASH_EXE=${EXIT_CRASH_EXE}
-DPRINT_STDIN_EXE=$<TARGET_FILE:print_stdin>
- -DPython_EXECUTABLE=${Python_EXECUTABLE}
-DCYGWIN=${CYGWIN}
)
if(NOT CMake_TEST_EXTERNAL_CMAKE)