summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@crascit.com>2024-05-28 12:56:25 (GMT)
committerCraig Scott <craig.scott@crascit.com>2024-05-29 10:39:17 (GMT)
commitf588421b58f23b192670ad686e2797a09489a096 (patch)
treecbf003f0f9ddcb6aa049081ba238e43607b67825 /Tests/RunCMake/CMakeLists.txt
parent4370fcf7505bf0dc651478ab581f19c474278c59 (diff)
downloadCMake-f588421b58f23b192670ad686e2797a09489a096.zip
CMake-f588421b58f23b192670ad686e2797a09489a096.tar.gz
CMake-f588421b58f23b192670ad686e2797a09489a096.tar.bz2
FetchContent: Enforce FETCHCONTENT_FULLY_DISCONNECTED requirements
FETCHCONTENT_FULLY_DISCONNECTED should only be set to true if each dependency's source directory has already been populated. Previously, this wasn't being checked, but now it is (subject to a new policy).
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 8c047d0..5c1e5f6 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -176,6 +176,7 @@ add_RunCMake_test(CMP0160)
add_RunCMake_test(CMP0163)
add_RunCMake_test(CMP0165)
add_RunCMake_test(CMP0169)
+add_RunCMake_test(CMP0170)
# The test for Policy 65 requires the use of the
# CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS variable, which both the VS and Xcode