summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2024-05-22 18:51:02 (GMT)
committerBrad King <brad.king@kitware.com>2024-05-24 14:12:27 (GMT)
commitfa8c04b421d1d0af93d58c8e04ee0dce13ecb473 (patch)
tree75cec45a2408f6ce3faac6cad2f7ca791a9b7bf5 /Tests/RunCMake/CMakeLists.txt
parentd98df689abe69a90e94bb2a6af763e0e4fc18d08 (diff)
downloadCMake-fa8c04b421d1d0af93d58c8e04ee0dce13ecb473.zip
CMake-fa8c04b421d1d0af93d58c8e04ee0dce13ecb473.tar.gz
CMake-fa8c04b421d1d0af93d58c8e04ee0dce13ecb473.tar.bz2
Tests/RunCMake/execute_process: Check STARTUPINFOW reserved members
Verify that `execute_process` launches processes on Windows such that `GetStartupInfoW` in the child does not populate `STARTUPINFOW` members reserved for the MSVC C run-time. Issue: #25996
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index f10e72d..a9fe571 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -513,6 +513,10 @@ set(execute_process_ARGS
if(NOT CMake_TEST_EXTERNAL_CMAKE)
list(APPEND execute_process_ARGS -DTEST_ENCODING_EXE=$<TARGET_FILE:testEncoding>)
endif()
+if(WIN32)
+ add_executable(testStartupInfo testStartupInfo.c)
+ list(APPEND execute_process_ARGS -DTEST_STARTUPINFO_EXE=$<TARGET_FILE:testStartupInfo>)
+endif()
add_RunCMake_test(execute_process)
add_RunCMake_test(export)
if(CMake_TEST_MSYSTEM_PREFIX)