summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-02-18 15:35:53 (GMT)
committerBrad King <brad.king@kitware.com>2013-02-20 13:01:06 (GMT)
commite83e6a1c8c572548b2a8ce1e54f4fd0f60f32a70 (patch)
treea73ddfb7d5859958594e9f58cab8aa12c5d7a3bd /Tests/RunCMake/CMakeLists.txt
parentc307e1c911dbbafb1673799212a4e5f4e211b9f8 (diff)
downloadCMake-e83e6a1c8c572548b2a8ce1e54f4fd0f60f32a70.zip
CMake-e83e6a1c8c572548b2a8ce1e54f4fd0f60f32a70.tar.gz
CMake-e83e6a1c8c572548b2a8ce1e54f4fd0f60f32a70.tar.bz2
Test Unix Makefiles generator support for changing compilers
Add RunCMake.CompilerChange test to cover use of -DCMAKE_C_COMPILER=cc to change the compiler of an existing build tree. Also test for proper failure with -DCMAKE_C_COMPILER="" and no CC in the environment.
Diffstat (limited to 'Tests/RunCMake/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 320ebcc..c55bb3a 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
@@ -52,6 +52,9 @@ if(XCODE_VERSION AND "${XCODE_VERSION}" VERSION_LESS 3)
endif()
add_RunCMake_test(CMP0019)
+if(UNIX AND "${CMAKE_TEST_GENERATOR}" MATCHES "Unix Makefiles")
+ add_RunCMake_test(CompilerChange)
+endif()
add_RunCMake_test(ExternalData)
add_RunCMake_test(GeneratorExpression)
add_RunCMake_test(GeneratorToolset)