summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CPack/CMakeLists.txt
diff options
context:
space:
mode:
authorDomen Vrankar <domen.vrankar@gmail.com>2016-11-27 15:33:13 (GMT)
committerDomen Vrankar <domen.vrankar@gmail.com>2016-11-27 22:20:35 (GMT)
commitd040d1647d2192ab97db9b041599c9e224c93553 (patch)
treed9ef9808a5652b252186888075f9a97e6c3b3ddb /Tests/RunCMake/CPack/CMakeLists.txt
parent2cc479bdac84843d0284573cf801ee526e798c54 (diff)
downloadCMake-d040d1647d2192ab97db9b041599c9e224c93553.zip
CMake-d040d1647d2192ab97db9b041599c9e224c93553.tar.gz
CMake-d040d1647d2192ab97db9b041599c9e224c93553.tar.bz2
Tests: CPack test set packaging type
CPack tests can now define one or more packaging types and that test will be executed once per generator per packaging type. This also enables us to set default values per packaging type for each generator which makes tests shorter.
Diffstat (limited to 'Tests/RunCMake/CPack/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CPack/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/RunCMake/CPack/CMakeLists.txt b/Tests/RunCMake/CPack/CMakeLists.txt
index e06fa1c..c361af0 100644
--- a/Tests/RunCMake/CPack/CMakeLists.txt
+++ b/Tests/RunCMake/CPack/CMakeLists.txt
@@ -1,7 +1,13 @@
cmake_minimum_required(VERSION 3.1 FATAL_ERROR)
+set(CMAKE_BUILD_TYPE "Debug" CACHE STRING "")
+
project(${RunCMake_TEST} CXX)
+if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/${GENERATOR_TYPE}/packaging_${PACKAGING_TYPE}_default.cmake")
+ include(${GENERATOR_TYPE}/packaging_${PACKAGING_TYPE}_default.cmake)
+endif()
+
# set default test name (can be overwritten in test.cmake or specifics.cmake)
string(TOLOWER "${RunCMake_TEST_FILE_PREFIX}" CPACK_PACKAGE_NAME)