summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CPackCommandLine/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-11-11 18:58:25 (GMT)
committerBrad King <brad.king@kitware.com>2019-11-11 19:16:48 (GMT)
commit1d1fa5d3e4f3594f1c1db258e526c4b747117aa2 (patch)
tree485ed4fdfa0ef330dec9afe87bf2b4146130464c /Tests/RunCMake/CPackCommandLine/CMakeLists.txt
parent108207cc849b3c6f3de57c5ba8676465510d0849 (diff)
downloadCMake-1d1fa5d3e4f3594f1c1db258e526c4b747117aa2.zip
CMake-1d1fa5d3e4f3594f1c1db258e526c4b747117aa2.tar.gz
CMake-1d1fa5d3e4f3594f1c1db258e526c4b747117aa2.tar.bz2
Tests: Add RunCMake.CPackCommandLine case for multi-config package
In commit da5ac4bb60 (cpack: Add `CPACK_INSTALL_CMAKE_CONFIGURATIONS` variable, 2019-07-10, v3.16.0-rc1~165^2) we added support for running the `cpack -C ...` command-line with multiple configurations. Add an explicit test for this. Fixes: #19918
Diffstat (limited to 'Tests/RunCMake/CPackCommandLine/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CPackCommandLine/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/CPackCommandLine/CMakeLists.txt b/Tests/RunCMake/CPackCommandLine/CMakeLists.txt
new file mode 100644
index 0000000..2632ffa
--- /dev/null
+++ b/Tests/RunCMake/CPackCommandLine/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 3.16)
+project(${RunCMake_TEST} NONE)
+include(${RunCMake_TEST}.cmake)