summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/CheckModules/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2014-12-16 21:11:40 (GMT)
committerStephen Kelly <steveire@gmail.com>2014-12-31 15:34:34 (GMT)
commit73ae888506c89b8c0619905f4c19b79116afb514 (patch)
treec7af7e40b479536d725266181876cefb735947a9 /Tests/RunCMake/CheckModules/CMakeLists.txt
parentc2445d3dfd837cd2e372061f5545054317be110a (diff)
downloadCMake-73ae888506c89b8c0619905f4c19b79116afb514.zip
CMake-73ae888506c89b8c0619905f4c19b79116afb514.tar.gz
CMake-73ae888506c89b8c0619905f4c19b79116afb514.tar.bz2
RunCMake: Expect empty output by default.
Expect tests to specify stderr content if it is present. Fix the CMP0019 test, which has only been testing the WARN status until now. Specify in the CommandLine and FPHSA tests that content is at least one character. Set policies in the Language and CheckModules tests, which have empty test output, modulo unrelated policies on some platforms.
Diffstat (limited to 'Tests/RunCMake/CheckModules/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CheckModules/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/RunCMake/CheckModules/CMakeLists.txt b/Tests/RunCMake/CheckModules/CMakeLists.txt
index 72abfc8..9872df2 100644
--- a/Tests/RunCMake/CheckModules/CMakeLists.txt
+++ b/Tests/RunCMake/CheckModules/CMakeLists.txt
@@ -1,3 +1,4 @@
cmake_minimum_required(VERSION 2.8.11)
+cmake_policy(SET CMP0054 NEW)
project(${RunCMake_TEST} NONE)
include(${RunCMake_TEST}.cmake)