summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/Configure/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-07-09 18:35:49 (GMT)
committerBrad King <brad.king@kitware.com>2013-07-09 19:00:39 (GMT)
commit18e1bfbb3c2515b1b33d95f53e1dd7f10e3f54c4 (patch)
treecc1a2d7500a307af64a3dbbf2c185efde93a0b38 /Tests/RunCMake/Configure/CMakeLists.txt
parent448a67714825a6d3018a6974153de6771080a8e6 (diff)
downloadCMake-18e1bfbb3c2515b1b33d95f53e1dd7f10e3f54c4.zip
CMake-18e1bfbb3c2515b1b33d95f53e1dd7f10e3f54c4.tar.gz
CMake-18e1bfbb3c2515b1b33d95f53e1dd7f10e3f54c4.tar.bz2
cmake: On configure error suggest looking at CMake*.log files
When CMake reports failure to configure a project, especially when the toolchain does not initialize properly, the true reason may be clear from reading the CMakeFiles/CMake(Output|Error).log files. Advise users to look at these files if they exist when configuration fails. Add RunCMake.Configure test to check that the log files are mentioned when configuration fails.
Diffstat (limited to 'Tests/RunCMake/Configure/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/Configure/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/Configure/CMakeLists.txt b/Tests/RunCMake/Configure/CMakeLists.txt
new file mode 100644
index 0000000..e8db6b0
--- /dev/null
+++ b/Tests/RunCMake/Configure/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 2.8)
+project(${RunCMake_TEST} NONE)
+include(${RunCMake_TEST}.cmake)