summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/DisallowedCommands/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-18 15:54:09 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-22 13:09:51 (GMT)
commit882c0f0b698e70be8b74aa498b62cb1fb22f3c24 (patch)
tree9154c655d59026c3ccf89b72f8e34da36694939d /Tests/RunCMake/DisallowedCommands/CMakeLists.txt
parentddef8a7cfffbbae12f2d2c556651f06346237569 (diff)
downloadCMake-882c0f0b698e70be8b74aa498b62cb1fb22f3c24.zip
CMake-882c0f0b698e70be8b74aa498b62cb1fb22f3c24.tar.gz
CMake-882c0f0b698e70be8b74aa498b62cb1fb22f3c24.tar.bz2
Add infrastructure for policies that disallow commands
Add cmCommand::Disallowed helper to check the setting of a policy that disallows the command. Add a RunCMake.DisallowedCommands test placeholder. Add a Help/policy/DISALLOWED_COMMAND.txt file for inclusion by each policy document to avoid duplication of the common text.
Diffstat (limited to 'Tests/RunCMake/DisallowedCommands/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/DisallowedCommands/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/DisallowedCommands/CMakeLists.txt b/Tests/RunCMake/DisallowedCommands/CMakeLists.txt
new file mode 100644
index 0000000..e8db6b0
--- /dev/null
+++ b/Tests/RunCMake/DisallowedCommands/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 2.8)
+project(${RunCMake_TEST} NONE)
+include(${RunCMake_TEST}.cmake)