summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/FetchContent/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-01-15 18:25:56 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-01-15 18:26:02 (GMT)
commitda566d4de885130e182edc80f13691f5ca24bb61 (patch)
treed16c9d04118115b387758ebcfbcf11a6d0c5822f /Tests/RunCMake/FetchContent/CMakeLists.txt
parent41b0c0dc739c34550b8e9054b9a88405afb6518d (diff)
parent2119c33b7e7b5fc348c0b4b24e402bcacb18d5db (diff)
downloadCMake-da566d4de885130e182edc80f13691f5ca24bb61.zip
CMake-da566d4de885130e182edc80f13691f5ca24bb61.tar.gz
CMake-da566d4de885130e182edc80f13691f5ca24bb61.tar.bz2
Merge topic 'fetchcontent-uses-terminal'
2119c33b7e FetchContent: Give access to the terminal for download and update Acked-by: Kitware Robot <kwrobot@kitware.com> Acked-by: Michael Hirsch, Ph.D. <michael@scivision.co> Merge-request: !2800
Diffstat (limited to 'Tests/RunCMake/FetchContent/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/FetchContent/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/RunCMake/FetchContent/CMakeLists.txt b/Tests/RunCMake/FetchContent/CMakeLists.txt
index d3137f6..3cc2e43 100644
--- a/Tests/RunCMake/FetchContent/CMakeLists.txt
+++ b/Tests/RunCMake/FetchContent/CMakeLists.txt
@@ -1,3 +1,7 @@
cmake_minimum_required(VERSION 3.9)
project(${RunCMake_TEST} NONE)
+
+# Tests assume no previous downloads in the output directory
+file(REMOVE_RECURSE ${CMAKE_CURRENT_BINARY_DIR}/_deps)
+
include(${RunCMake_TEST}.cmake)