summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/ObjectLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorDeniz Bahadir <dbahadir@benocs.com>2017-11-23 11:59:20 (GMT)
committerBrad King <brad.king@kitware.com>2018-03-01 14:24:24 (GMT)
commit51249e69eaab33fe43805b9fe2262b4ddab01b56 (patch)
tree1a33d55faf49c0bd9107ea4be7ac8efa756ebea2 /Tests/RunCMake/ObjectLibrary/CMakeLists.txt
parente22c45d4c97c713734b8349132fa881f602f7ae3 (diff)
downloadCMake-51249e69eaab33fe43805b9fe2262b4ddab01b56.zip
CMake-51249e69eaab33fe43805b9fe2262b4ddab01b56.tar.gz
CMake-51249e69eaab33fe43805b9fe2262b4ddab01b56.tar.bz2
objlib: Allow `OBJECT` libraries to link to other libraries.
The proper way to use libraries is now through `target_link_libraries` for things such as usage requirements, compile definitions, include directories, etc. To facilitate this, allow `OBJECT` libraries to "link" to other libraries. Co-Author: Ben Boeckel <ben.boeckel@kitware.com> Issue: #14778
Diffstat (limited to 'Tests/RunCMake/ObjectLibrary/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/ObjectLibrary/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/RunCMake/ObjectLibrary/CMakeLists.txt b/Tests/RunCMake/ObjectLibrary/CMakeLists.txt
index a17c8cd..d1b0d2c 100644
--- a/Tests/RunCMake/ObjectLibrary/CMakeLists.txt
+++ b/Tests/RunCMake/ObjectLibrary/CMakeLists.txt
@@ -1,3 +1,3 @@
-cmake_minimum_required(VERSION 2.8.4)
+cmake_minimum_required(VERSION 3.10)
project(${RunCMake_TEST} C)
include(${RunCMake_TEST}.cmake)