summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/PrintHelpers/CMakeLists.txt
diff options
context:
space:
mode:
authorFeRD (Frank Dana) <ferdnyc@gmail.com>2022-06-05 17:18:16 (GMT)
committerFeRD (Frank Dana) <ferdnyc@gmail.com>2022-06-06 16:27:11 (GMT)
commitd8dcfa7776002756efbc30e45be305e425103e31 (patch)
tree1f6757ecaeb65f48e16b8fec43d4dcb706bcf412 /Tests/RunCMake/PrintHelpers/CMakeLists.txt
parentb7ddfcfe084ac1c2652dab524938f84dc37f6230 (diff)
downloadCMake-d8dcfa7776002756efbc30e45be305e425103e31.zip
CMake-d8dcfa7776002756efbc30e45be305e425103e31.tar.gz
CMake-d8dcfa7776002756efbc30e45be305e425103e31.tar.bz2
Tests: Add tests for CMakePrintHelpers
Add three tests in Tests/RunCMake/PrintHelpers, meant to verify basic functionality of the module. Tests are: * Variables: Test the results of a cmake_print_variables() call on two variables set within the test script. * Properties: Test cmake_print_properties() calls on a pair of SOURCES and a pair of TARGETS, printing some basic properties. * PropertiesSources: Specifically verify the results of a cmake_print_properties() call for the SOURCES property of a TARGET. Prior to the fix introduced alongside these tests, it was a known bug that such a request caused a FATAL_ERROR.
Diffstat (limited to 'Tests/RunCMake/PrintHelpers/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/PrintHelpers/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/PrintHelpers/CMakeLists.txt b/Tests/RunCMake/PrintHelpers/CMakeLists.txt
new file mode 100644
index 0000000..6d4fe63
--- /dev/null
+++ b/Tests/RunCMake/PrintHelpers/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 3.23)
+project(${RunCMake_TEST} C)
+include(${RunCMake_TEST}.cmake)