summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/WriteCompilerDetectionHeader/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-10-21 14:59:40 (GMT)
committerBrad King <brad.king@kitware.com>2014-05-14 17:57:30 (GMT)
commit62a4a67dc54f3b796cd2735b230a863815d932b2 (patch)
tree004d214d0fbfd240540b5941601cd39b86d4a549 /Tests/RunCMake/WriteCompilerDetectionHeader/CMakeLists.txt
parentf782417b8cf3d9295ce33ca7214674e5db03efdd (diff)
downloadCMake-62a4a67dc54f3b796cd2735b230a863815d932b2.zip
CMake-62a4a67dc54f3b796cd2735b230a863815d932b2.tar.gz
CMake-62a4a67dc54f3b796cd2735b230a863815d932b2.tar.bz2
Add the WriteCompilerDetectionHeader module.
Provide a function to write a portable header to detect compiler features. Generate a preprocessor #error for unknown compilers and compiler versions whose features are not yet recorded. This error condition might be relaxed in the future, but for now it is useful for verification of expectations.
Diffstat (limited to 'Tests/RunCMake/WriteCompilerDetectionHeader/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/WriteCompilerDetectionHeader/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/WriteCompilerDetectionHeader/CMakeLists.txt b/Tests/RunCMake/WriteCompilerDetectionHeader/CMakeLists.txt
new file mode 100644
index 0000000..872338d
--- /dev/null
+++ b/Tests/RunCMake/WriteCompilerDetectionHeader/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 3.0)
+project(${RunCMake_TEST} CXX)
+include(${RunCMake_TEST}.cmake NO_POLICY_SCOPE)