summaryrefslogtreecommitdiffstats
path: root/Tests/RunCMake/XcodeProject-Embed/CMakeLists.txt
diff options
context:
space:
mode:
authorGusts Kaksis <gusts.kaksis@sonarworks.com>2020-10-24 10:41:13 (GMT)
committerCraig Scott <craig.scott@crascit.com>2020-11-28 04:36:24 (GMT)
commit5651901c54ac74912110ba0d2395b25a96570326 (patch)
tree10df62d0144f44027e8bcecb7d34038d85a21706 /Tests/RunCMake/XcodeProject-Embed/CMakeLists.txt
parent70f11b9d3c5d2cfd81b2e33cc6c315cd9b2d1473 (diff)
downloadCMake-5651901c54ac74912110ba0d2395b25a96570326.zip
CMake-5651901c54ac74912110ba0d2395b25a96570326.tar.gz
CMake-5651901c54ac74912110ba0d2395b25a96570326.tar.bz2
Xcode: add support for embedding frameworks
This commit also prepares for embedding things other than frameworks. In the future, we may want to embed resources and other types supported by Xcode, so the target properties have been documented in a way that clearly signals the future intent.
Diffstat (limited to 'Tests/RunCMake/XcodeProject-Embed/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/XcodeProject-Embed/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/XcodeProject-Embed/CMakeLists.txt b/Tests/RunCMake/XcodeProject-Embed/CMakeLists.txt
new file mode 100644
index 0000000..0400d1a
--- /dev/null
+++ b/Tests/RunCMake/XcodeProject-Embed/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 3.19)
+project(${RunCMake_TEST} LANGUAGES C)
+include(${RunCMake_TEST}.cmake)