summaryrefslogtreecommitdiffstats
path: root/Tests/SetLang/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2007-02-20 14:35:21 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2007-02-20 14:35:21 (GMT)
commit1d8e7e9411f62a60340b1edba6c55a8e7548a93b (patch)
tree932198ce265b630740c8340c0e2d0a8a723919bc /Tests/SetLang/CMakeLists.txt
parent5c0a340a9e0146841b14065497373cb9a79d5768 (diff)
downloadCMake-1d8e7e9411f62a60340b1edba6c55a8e7548a93b.zip
CMake-1d8e7e9411f62a60340b1edba6c55a8e7548a93b.tar.gz
CMake-1d8e7e9411f62a60340b1edba6c55a8e7548a93b.tar.bz2
BUG: fix for bug 4423 set language fixes
Diffstat (limited to 'Tests/SetLang/CMakeLists.txt')
-rw-r--r--Tests/SetLang/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/SetLang/CMakeLists.txt b/Tests/SetLang/CMakeLists.txt
new file mode 100644
index 0000000..d53b308
--- /dev/null
+++ b/Tests/SetLang/CMakeLists.txt
@@ -0,0 +1,7 @@
+# test forcing a source file language to c++ from c
+project(SetLang)
+add_library(foo foo.c)
+add_executable(bar bar.c)
+set_source_files_properties(foo.c bar.c PROPERTIES LANGUAGE CXX)
+target_link_libraries(bar foo)
+set_target_properties(bar PROPERTIES LINKER_LANGUAGE CXX)