summaryrefslogtreecommitdiffstats
path: root/Tests/SimpleCOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-06-26 19:30:02 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-06-26 19:30:02 (GMT)
commitae47302529e9ee040a45ad9a8636e6116e880d0c (patch)
treef75d758cb83ae21d7c02248e75cd6a3d92457f1d /Tests/SimpleCOnly/CMakeLists.txt
parent25a425ecf09fccc804758da1015f93fce724f856 (diff)
downloadCMake-ae47302529e9ee040a45ad9a8636e6116e880d0c.zip
CMake-ae47302529e9ee040a45ad9a8636e6116e880d0c.tar.gz
CMake-ae47302529e9ee040a45ad9a8636e6116e880d0c.tar.bz2
ENH: add a SimpleCOnly test, this is needed e.g. for testing sdcc since this
doesn't support C++ and also doesn't have a printf() implementation by default -add a test for mingw cross compiler Alex
Diffstat (limited to 'Tests/SimpleCOnly/CMakeLists.txt')
-rw-r--r--Tests/SimpleCOnly/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/Tests/SimpleCOnly/CMakeLists.txt b/Tests/SimpleCOnly/CMakeLists.txt
new file mode 100644
index 0000000..d0ed651
--- /dev/null
+++ b/Tests/SimpleCOnly/CMakeLists.txt
@@ -0,0 +1,17 @@
+# this enables only C, i.e. disables C++
+project(SimpleCOnly C)
+
+add_library(SimpleCLib STATIC bar.c foo.c)
+
+add_executable(SimpleC main.c)
+target_link_libraries(SimpleC SimpleCLib)
+
+# and some check, just to make sure it works:
+include(CheckTypeSize)
+check_type_size(float SIZE_FLOAT)
+message(STATUS "sizeof(float): ${SIZE_FLOAT}")
+
+# make sure optimized libs are not used by debug builds
+if(CMAKE_BUILD_TYPE MATCHES Debug)
+ target_link_libraries(Simple optimized c:/not/here.lib )
+endif(CMAKE_BUILD_TYPE MATCHES Debug)