summaryrefslogtreecommitdiffstats
path: root/Tests/SimpleInstall/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-06-01 16:55:23 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-06-01 16:55:23 (GMT)
commit5bbfbd56f584a43b13f3b2409f168bcfd6e02411 (patch)
treee992f012c3df6b75d027a9499eeaf1f69cc88ee8 /Tests/SimpleInstall/CMakeLists.txt
parent2936c54cdd4acfd402a0237b29b96d718c64ffbf (diff)
downloadCMake-5bbfbd56f584a43b13f3b2409f168bcfd6e02411.zip
CMake-5bbfbd56f584a43b13f3b2409f168bcfd6e02411.tar.gz
CMake-5bbfbd56f584a43b13f3b2409f168bcfd6e02411.tar.bz2
ENH: More elaborate install test
Diffstat (limited to 'Tests/SimpleInstall/CMakeLists.txt')
-rw-r--r--Tests/SimpleInstall/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/SimpleInstall/CMakeLists.txt b/Tests/SimpleInstall/CMakeLists.txt
index df9a644..0221da3 100644
--- a/Tests/SimpleInstall/CMakeLists.txt
+++ b/Tests/SimpleInstall/CMakeLists.txt
@@ -50,6 +50,8 @@ IF(STAGE2)
INSTALL_TARGETS(/bin SimpleInstallS2)
ELSE(STAGE2)
+ SUBDIRS(PREORDER TestSubDir)
+
# this is stage 1, so create libraries and modules and install everything
ADD_LIBRARY(test1 STATIC lib1.cxx)
ADD_LIBRARY(test2 SHARED lib2.cxx)
@@ -65,6 +67,7 @@ ELSE(STAGE2)
INSTALL_TARGETS(/bin SimpleInstall)
INSTALL_TARGETS(/lib test1 test2 test3)
INSTALL_TARGETS(/include lib1.h lib2.h lib3.h)
+
SET_TARGET_PROPERTIES(SimpleInstall PROPERTIES PRE_INSTALL_SCRIPT
${CMAKE_CURRENT_SOURCE_DIR}/PreInstall.cmake)
SET_TARGET_PROPERTIES(SimpleInstall PROPERTIES POST_INSTALL_SCRIPT