summaryrefslogtreecommitdiffstats
path: root/Tests/SimpleInstall/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-04-13 02:04:50 (GMT)
committerBrad King <brad.king@kitware.com>2006-04-13 02:04:50 (GMT)
commitd4c5fe840beb029cb60572cabd643feb4e239830 (patch)
tree3bc37efec89d6bf17f6c5cd1efef91d236744031 /Tests/SimpleInstall/CMakeLists.txt
parent58641b2ceb5d3401e1cb0e4bb897a9fe2329e525 (diff)
downloadCMake-d4c5fe840beb029cb60572cabd643feb4e239830.zip
CMake-d4c5fe840beb029cb60572cabd643feb4e239830.tar.gz
CMake-d4c5fe840beb029cb60572cabd643feb4e239830.tar.bz2
ENH: Added INSTALL(CODE) mode to allow inline specification of install script code. This reduces the need for configuring an install script that needs some variable settings because the install code can set thing up first.
Diffstat (limited to 'Tests/SimpleInstall/CMakeLists.txt')
-rw-r--r--Tests/SimpleInstall/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/SimpleInstall/CMakeLists.txt b/Tests/SimpleInstall/CMakeLists.txt
index 0ba9fe4..ac8f12e 100644
--- a/Tests/SimpleInstall/CMakeLists.txt
+++ b/Tests/SimpleInstall/CMakeLists.txt
@@ -122,6 +122,7 @@ ELSE(STAGE2)
# Test user-specified install scripts.
INSTALL(
SCRIPT InstallScript1.cmake
+ CODE "SET(INSTALL_CODE_DID_RUN 1)"
SCRIPT ${CMAKE_CURRENT_SOURCE_DIR}/InstallScript2.cmake
)
SET_DIRECTORY_PROPERTIES(PROPERTIES