summaryrefslogtreecommitdiffstats
path: root/Tests/SimpleInstallS2/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-11-19 15:55:39 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-11-19 15:55:39 (GMT)
commit1da77bf1ee4f3ba315ebb00da2eaeac474614cad (patch)
tree3832a8e9ce070baea6434691201d873bb54f3958 /Tests/SimpleInstallS2/CMakeLists.txt
parent856468213640417d401c6ff70c1f43c1c31145dc (diff)
parent4cce44b6c50a40ee13f423ae311d5db5a66a13f4 (diff)
downloadCMake-1da77bf1ee4f3ba315ebb00da2eaeac474614cad.zip
CMake-1da77bf1ee4f3ba315ebb00da2eaeac474614cad.tar.gz
CMake-1da77bf1ee4f3ba315ebb00da2eaeac474614cad.tar.bz2
Merge topic 'cleanup-build-commands'
4cce44b Help: Document the CMAKE_MAKE_PROGRAM variable in more detail 558c74d VS: Switch to internal CMAKE_MAKE_PROGRAM lookup by generators 5229f2d Tests: Do not use an explicit make program for VS generators 72dd738 Tests: Fix MFC test heuristic for empty CMAKE_TEST_MAKEPROGRAM fd6076d Tests: Pass CMAKE_MAKE_PROGRAM instead of --build-makeprogram 68031ab Tests: Configure SubProject-Stage2 test more robustly 003d10c Tests: Simplify VSExcludeFromDefaultBuild configuration e47d934 Tests: Simplify VSProjectInSubdir configuration e965cb1 Tests: Simplify CTest.BuildCommand.ProjectInSubdir configuration 72bf255 Tests: Pass --build-options to every test 4d1d772 ctest: Teach --build-options to allow zero options 96966b5 ctest: Make the --build-makeprogram optional for --build-and-test 91a0211 Simplify some calls to cmGlobalGenerator::Build 123a060 Teach GenerateBuildCommand to find its own make program 5f5c92b VS: Add internal APIs to find MSBuild, devenv/VCExpress, and msdev 4ac75fd Prefer CMAKE_MAKE_PROGRAM over CMAKE_BUILD_TOOL (#14548) ...
Diffstat (limited to 'Tests/SimpleInstallS2/CMakeLists.txt')
-rw-r--r--Tests/SimpleInstallS2/CMakeLists.txt25
1 files changed, 11 insertions, 14 deletions
diff --git a/Tests/SimpleInstallS2/CMakeLists.txt b/Tests/SimpleInstallS2/CMakeLists.txt
index b969bfd..cc3c3be 100644
--- a/Tests/SimpleInstallS2/CMakeLists.txt
+++ b/Tests/SimpleInstallS2/CMakeLists.txt
@@ -308,7 +308,7 @@ else()
endif()
if(CMAKE_CONFIGURATION_TYPES)
- set(SI_CONFIG -C ${CMAKE_CFG_INTDIR})
+ set(SI_CONFIG --config $<CONFIGURATION>)
else()
set(SI_CONFIG)
endif()
@@ -367,7 +367,9 @@ set(CMAKE_INSTALL_DEBUG_LIBRARIES 1)
include(InstallRequiredSystemLibraries)
if(CTEST_TEST_CPACK)
- set(PACKAGE_TARGET --build-target package)
+ set(package_command COMMAND
+ ${CMAKE_COMMAND} --build . --target package ${SI_CONFIG}
+ )
# Avoid settings that require the .zip file command line tools...
# (just build an NSIS installer without component support)
@@ -375,24 +377,19 @@ if(CTEST_TEST_CPACK)
set(CPACK_BINARY_ZIP OFF)
set(CPACK_MONOLITHIC_INSTALL ON)
else()
- set(PACKAGE_TARGET)
+ set(package_command)
endif()
include(CPack)
+set(install_command COMMAND
+ ${CMAKE_COMMAND} --build . --target install ${SI_CONFIG}
+ )
+
add_custom_command(
TARGET ${install_target}
POST_BUILD
- COMMAND ${CMAKE_CTEST_COMMAND}
- ARGS ${SI_CONFIG}
- --build-and-test
- ${CMAKE_SOURCE_DIR}
- ${CMAKE_BINARY_DIR}
- --build-generator ${CMAKE_GENERATOR}
- --build-project ${PROJECT_NAME}
- --build-makeprogram ${CMAKE_MAKE_PROGRAM}
- --build-noclean
- --build-target install
- ${PACKAGE_TARGET}
+ ${install_command}
+ ${package_command}
COMMENT "Install Project"
)