summaryrefslogtreecommitdiffstats
path: root/Tests/SourceFileProperty/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-12-03 15:02:05 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2014-12-03 15:02:05 (GMT)
commitd91feda4136b8fb9bc3002b38ba8c08fca9cd62c (patch)
tree90094402755bdc7e92a6daeb6ddec063a199536e /Tests/SourceFileProperty/CMakeLists.txt
parent9843dfab4486f76cab567862e504a71d1ecc58a5 (diff)
parentb7d760aea20f70b221fcba7ecb2c7edf7751ffc2 (diff)
downloadCMake-d91feda4136b8fb9bc3002b38ba8c08fca9cd62c.zip
CMake-d91feda4136b8fb9bc3002b38ba8c08fca9cd62c.tar.gz
CMake-d91feda4136b8fb9bc3002b38ba8c08fca9cd62c.tar.bz2
Merge topic 'icase-source-file-prop'
b7d760ae test: test source file properties with case-insensitivity
Diffstat (limited to 'Tests/SourceFileProperty/CMakeLists.txt')
-rw-r--r--Tests/SourceFileProperty/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/Tests/SourceFileProperty/CMakeLists.txt b/Tests/SourceFileProperty/CMakeLists.txt
new file mode 100644
index 0000000..1b6506d
--- /dev/null
+++ b/Tests/SourceFileProperty/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 3.0)
+project(SourceFileProperty C)
+
+set(sources)
+
+if (EXISTS icasetest.c)
+ # If a file exists by this name, use it.
+ set_source_files_properties(icasetest.c
+ PROPERTIES
+ COMPILE_FLAGS -DNEEDED_TO_WORK)
+else ()
+ # Work on case-sensitive file systems as well.
+ set_source_files_properties(main.c
+ PROPERTIES
+ COMPILE_FLAGS -DNO_NEED_TO_CALL)
+endif ()
+list(APPEND sources ICaseTest.c)
+
+add_executable(SourceFileProperty main.c ${sources})