summaryrefslogtreecommitdiffstats
path: root/Tests/SourceGroups/CMakeLists.txt
diff options
context:
space:
mode:
authorMateusz Janek <stryku2393@gmail.com>2016-12-21 14:27:49 (GMT)
committerBrad King <brad.king@kitware.com>2017-01-16 15:52:48 (GMT)
commitb42330be21c0d3046aa0e6fdf046a492bddef520 (patch)
treeefd6fbbda9401a36000f2c3b265b9d43310348e6 /Tests/SourceGroups/CMakeLists.txt
parent6154a2cddcdb297b1aef20f501fec9af7d7b5262 (diff)
downloadCMake-b42330be21c0d3046aa0e6fdf046a492bddef520.zip
CMake-b42330be21c0d3046aa0e6fdf046a492bddef520.tar.gz
CMake-b42330be21c0d3046aa0e6fdf046a492bddef520.tar.bz2
source_group: Add options create groups matching directory tree
Add `TREE` and `PREFIX` arguments to enable this behavior.
Diffstat (limited to 'Tests/SourceGroups/CMakeLists.txt')
-rw-r--r--Tests/SourceGroups/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/Tests/SourceGroups/CMakeLists.txt b/Tests/SourceGroups/CMakeLists.txt
index 6573c82..9289e84 100644
--- a/Tests/SourceGroups/CMakeLists.txt
+++ b/Tests/SourceGroups/CMakeLists.txt
@@ -30,6 +30,17 @@ source_group(Base\\Sub1\\Base FILES bar.c)
# a group without files, is currently not created
source_group(EmptyGroup)
+set(root ${CMAKE_CURRENT_SOURCE_DIR})
-add_executable(SourceGroups main.c bar.c foo.c sub1/foo.c sub1/foobar.c baz.c README.txt)
+set(tree_files_without_prefix ${root}/sub1/tree_bar.c
+ ${root}/sub1/tree_baz.c
+ ${root}/sub1/tree_subdir/tree_foobar.c)
+set(tree_files_with_prefix ${root}/tree_foo.c)
+
+source_group(TREE ${root} FILES ${tree_files_without_prefix})
+
+source_group(TREE ${root} PREFIX tree_root/subgroup FILES ${tree_files_with_prefix})
+
+add_executable(SourceGroups main.c bar.c foo.c sub1/foo.c sub1/foobar.c baz.c
+ ${tree_files_with_prefix} ${tree_files_without_prefix} README.txt)