summaryrefslogtreecommitdiffstats
path: root/Tests/SourcesProperty/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2014-02-13 19:52:21 (GMT)
committerStephen Kelly <steveire@gmail.com>2014-04-02 21:14:02 (GMT)
commit3676fb49634efd01755aa5c12d58e2f2bf20d09f (patch)
tree9fa46bbd284083457ce0133ff27d03fd710e9c76 /Tests/SourcesProperty/CMakeLists.txt
parente6971df6ab647031ba9689c9afbbde78cc62e35f (diff)
downloadCMake-3676fb49634efd01755aa5c12d58e2f2bf20d09f.zip
CMake-3676fb49634efd01755aa5c12d58e2f2bf20d09f.tar.gz
CMake-3676fb49634efd01755aa5c12d58e2f2bf20d09f.tar.bz2
cmTarget: Allow transitive evaluation of SOURCES property.
Extend the cmGeneratorExpressionDAGChecker with an interface returning the name of the top target. Use that to determine when there is a DAG violation, as required by the RunCMake.Languages tests.
Diffstat (limited to 'Tests/SourcesProperty/CMakeLists.txt')
-rw-r--r--Tests/SourcesProperty/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/SourcesProperty/CMakeLists.txt b/Tests/SourcesProperty/CMakeLists.txt
new file mode 100644
index 0000000..0b3097e
--- /dev/null
+++ b/Tests/SourcesProperty/CMakeLists.txt
@@ -0,0 +1,10 @@
+
+cmake_minimum_required(VERSION 3.0)
+
+project(SourcesProperty)
+
+add_library(iface INTERFACE)
+set_property(TARGET iface PROPERTY INTERFACE_SOURCES iface.cpp)
+
+add_executable(SourcesProperty main.cpp)
+target_link_libraries(SourcesProperty iface)