summaryrefslogtreecommitdiffstats
path: root/Tests/StringFileTest/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2014-03-18 15:21:08 (GMT)
committerStephen Kelly <steveire@gmail.com>2014-03-31 21:18:44 (GMT)
commit28e1d2f8fc08516e8fc3a009777437d3e086b8e6 (patch)
tree6706855db40e1726ad1d5e29bf8c763c7286156e /Tests/StringFileTest/CMakeLists.txt
parentbf98cc252f18e761ed9a57d2f7a9304bfbb621de (diff)
downloadCMake-28e1d2f8fc08516e8fc3a009777437d3e086b8e6.zip
CMake-28e1d2f8fc08516e8fc3a009777437d3e086b8e6.tar.gz
CMake-28e1d2f8fc08516e8fc3a009777437d3e086b8e6.tar.bz2
cmStringCommand: Add GENEX_STRIP subcommand.
Strip out any generator expressions in the input string.
Diffstat (limited to 'Tests/StringFileTest/CMakeLists.txt')
-rw-r--r--Tests/StringFileTest/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/StringFileTest/CMakeLists.txt b/Tests/StringFileTest/CMakeLists.txt
index 00383ab..be6d8fe 100644
--- a/Tests/StringFileTest/CMakeLists.txt
+++ b/Tests/StringFileTest/CMakeLists.txt
@@ -286,3 +286,9 @@ string(MAKE_C_IDENTIFIER "1one-two$" MCI_1)
if(NOT MCI_1 STREQUAL _1one_two_)
message(SEND_ERROR "MAKE_C_IDENTIFIER did not create expected result.")
endif()
+
+string(GENEX_STRIP "one;$<1:two;three>;four;$<TARGET_OBJECTS:some_target>" strip_result)
+
+if (NOT strip_result STREQUAL "one;four")
+ message(SEND_ERROR "GENEX_STRIP did not create expected result: ${strip_result}")
+endif()