summaryrefslogtreecommitdiffstats
path: root/Tests/SubDir/CMakeLists.txt
diff options
context:
space:
mode:
authorKitware Robot <kwrobot@kitware.com>2012-08-13 17:47:32 (GMT)
committerBrad King <brad.king@kitware.com>2012-08-13 18:19:16 (GMT)
commit77543bde41b0e52c3959016698b529835945d62d (patch)
treeff63e5fbec326c4a5d821e7496c6d2cb52f75b92 /Tests/SubDir/CMakeLists.txt
parent7bbaa4283de26864b2e55e819db0884771585467 (diff)
downloadCMake-77543bde41b0e52c3959016698b529835945d62d.zip
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.gz
CMake-77543bde41b0e52c3959016698b529835945d62d.tar.bz2
Convert CMake-language commands to lower case
Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code: cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done >convert.sed && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' '*CMakeLists.txt' | egrep -z -v '^(Utilities/cm|Source/kwsys/)' | xargs -0 sed -i -f convert.sed && rm convert.sed
Diffstat (limited to 'Tests/SubDir/CMakeLists.txt')
-rw-r--r--Tests/SubDir/CMakeLists.txt64
1 files changed, 32 insertions, 32 deletions
diff --git a/Tests/SubDir/CMakeLists.txt b/Tests/SubDir/CMakeLists.txt
index cf8fe97..2aec956 100644
--- a/Tests/SubDir/CMakeLists.txt
+++ b/Tests/SubDir/CMakeLists.txt
@@ -1,46 +1,46 @@
cmake_minimum_required (VERSION 2.6)
-PROJECT(SUBDIR)
-SUBDIRS(Executable EXCLUDE_FROM_ALL Examples)
-WRITE_FILE(${SUBDIR_BINARY_DIR}/ShouldBeHere "This file should exist.")
+project(SUBDIR)
+subdirs(Executable EXCLUDE_FROM_ALL Examples)
+write_file(${SUBDIR_BINARY_DIR}/ShouldBeHere "This file should exist.")
#WATCOM WMAKE does not support + in the name of a file!
-IF(WATCOM)
- SET(PLUS_NAME_FILES
+if(WATCOM)
+ set(PLUS_NAME_FILES
AnotherSubdir/pair_int.int.c
vcl_algorithm_vcl_pair_double.foo.c)
-ELSE(WATCOM)
- SET(PLUS_NAME_FILES
+else(WATCOM)
+ set(PLUS_NAME_FILES
AnotherSubdir/pair+int.int.c
vcl_algorithm+vcl_pair+double.foo.c)
-ENDIF(WATCOM)
+endif(WATCOM)
-ADD_EXECUTABLE(TestFromSubdir
+add_executable(TestFromSubdir
AnotherSubdir/testfromsubdir.c
AnotherSubdir/secondone
${PLUS_NAME_FILES}
)
-AUX_SOURCE_DIRECTORY(ThirdSubDir SOURCES)
-IF(WATCOM)
- FOREACH(f ${SOURCES})
- IF("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
- ELSE("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
- SET(SOURCES2 ${f} ${SOURCES2})
- ENDIF("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
- ENDFOREACH(f)
- SET(SOURCES ${SOURCES2})
- SET(SOURCES ${SOURCES}
+aux_source_directory(ThirdSubDir SOURCES)
+if(WATCOM)
+ foreach(f ${SOURCES})
+ if("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
+ else("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
+ set(SOURCES2 ${f} ${SOURCES2})
+ endif("${f}" STREQUAL "ThirdSubDir/pair+int.int1.c")
+ endforeach(f)
+ set(SOURCES ${SOURCES2})
+ set(SOURCES ${SOURCES}
vcl_algorithm_vcl_pair_double.foo.c)
-ELSE(WATCOM)
- FOREACH(f ${SOURCES})
- IF("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
- ELSE("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
- SET(SOURCES2 ${f} ${SOURCES2})
- MESSAGE("${f}")
- ENDIF("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
- ENDFOREACH(f)
- SET(SOURCES ${SOURCES2})
- SET(SOURCES ${SOURCES}
+else(WATCOM)
+ foreach(f ${SOURCES})
+ if("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
+ else("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
+ set(SOURCES2 ${f} ${SOURCES2})
+ message("${f}")
+ endif("${f}" STREQUAL "ThirdSubDir/pair_int.int1.c")
+ endforeach(f)
+ set(SOURCES ${SOURCES2})
+ set(SOURCES ${SOURCES}
vcl_algorithm+vcl_pair+double.foo.c)
-ENDIF(WATCOM)
-MESSAGE("Sources: ${SOURCES}")
-ADD_EXECUTABLE(TestWithAuxSourceDir ${SOURCES})
+endif(WATCOM)
+message("Sources: ${SOURCES}")
+add_executable(TestWithAuxSourceDir ${SOURCES})