summaryrefslogtreecommitdiffstats
path: root/Tests/SubDir/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-04-26 21:32:56 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-04-26 21:32:56 (GMT)
commitd6090a2395a2e8e0c506e62a95e0e9dd197c6572 (patch)
tree3030c69e7dcc93a84fe308a73db6b45044661d4b /Tests/SubDir/CMakeLists.txt
parent62fec96d993975775410ebc2dceaa65b03a12ae2 (diff)
downloadCMake-d6090a2395a2e8e0c506e62a95e0e9dd197c6572.zip
CMake-d6090a2395a2e8e0c506e62a95e0e9dd197c6572.tar.gz
CMake-d6090a2395a2e8e0c506e62a95e0e9dd197c6572.tar.bz2
ENH: When source file is in subdirectory put object file in subdirectory. Fixes Bug #290 - Source files in subdirectories should produce object files in subdirectories
Diffstat (limited to 'Tests/SubDir/CMakeLists.txt')
-rw-r--r--Tests/SubDir/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/SubDir/CMakeLists.txt b/Tests/SubDir/CMakeLists.txt
index b70b312..a1da9b6 100644
--- a/Tests/SubDir/CMakeLists.txt
+++ b/Tests/SubDir/CMakeLists.txt
@@ -1,3 +1,5 @@
PROJECT(SUBDIR)
SUBDIRS(Executable EXCLUDE_FROM_ALL Examples)
WRITE_FILE(${SUBDIR_BINARY_DIR}/ShouldBeHere "This file should exist.")
+
+ADD_EXECUTABLE(TestFromSubdir AnotherSubdir/testfromsubdir.c AnotherSubdir/secondone)