summaryrefslogtreecommitdiffstats
path: root/Tests/SubDir/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-04-27 13:22:57 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-04-27 13:22:57 (GMT)
commit482eef71122acf6408e0d5bd02161bb832155f08 (patch)
tree61500ef9273621f9d8816b2286ed6c8838137e30 /Tests/SubDir/CMakeLists.txt
parentc19a70b3ada66a59c7a0ff78bf1a4a1cd557db9a (diff)
downloadCMake-482eef71122acf6408e0d5bd02161bb832155f08.zip
CMake-482eef71122acf6408e0d5bd02161bb832155f08.tar.gz
CMake-482eef71122acf6408e0d5bd02161bb832155f08.tar.bz2
BUG: Fix aus source dir and add better testing of it
Diffstat (limited to 'Tests/SubDir/CMakeLists.txt')
-rw-r--r--Tests/SubDir/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/Tests/SubDir/CMakeLists.txt b/Tests/SubDir/CMakeLists.txt
index a1da9b6..5cf8859 100644
--- a/Tests/SubDir/CMakeLists.txt
+++ b/Tests/SubDir/CMakeLists.txt
@@ -2,4 +2,15 @@ PROJECT(SUBDIR)
SUBDIRS(Executable EXCLUDE_FROM_ALL Examples)
WRITE_FILE(${SUBDIR_BINARY_DIR}/ShouldBeHere "This file should exist.")
-ADD_EXECUTABLE(TestFromSubdir AnotherSubdir/testfromsubdir.c AnotherSubdir/secondone)
+ADD_EXECUTABLE(TestFromSubdir
+ AnotherSubdir/testfromsubdir.c
+ AnotherSubdir/secondone
+ AnotherSubdir/pair+int.int.c
+ vcl_algorithm+vcl_pair+double.foo.c
+ )
+
+AUX_SOURCE_DIRECTORY(ThirdSubDir SOURCES)
+SET(SOURCES ${SOURCES}
+ vcl_algorithm+vcl_pair+double.foo.c)
+MESSAGE("Sources: ${SOURCES}")
+ADD_EXECUTABLE(TestWithAuxSourceDir ${SOURCES})