summaryrefslogtreecommitdiffstats
path: root/Tests/SubDirSpaces/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2007-02-22 02:24:17 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2007-02-22 02:24:17 (GMT)
commit5647e6e254f82a81997cd3913f872b06fe761f1e (patch)
tree50022ba8365b2c196965087a23a86cb848e36302 /Tests/SubDirSpaces/CMakeLists.txt
parent806001bbb633a27624e9a0f5e564cab3bfefb0c3 (diff)
downloadCMake-5647e6e254f82a81997cd3913f872b06fe761f1e.zip
CMake-5647e6e254f82a81997cd3913f872b06fe761f1e.tar.gz
CMake-5647e6e254f82a81997cd3913f872b06fe761f1e.tar.bz2
ENH: fix parens in the path with spaces in the path
Diffstat (limited to 'Tests/SubDirSpaces/CMakeLists.txt')
-rw-r--r--Tests/SubDirSpaces/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Tests/SubDirSpaces/CMakeLists.txt b/Tests/SubDirSpaces/CMakeLists.txt
index 3535070..29f4f64 100644
--- a/Tests/SubDirSpaces/CMakeLists.txt
+++ b/Tests/SubDirSpaces/CMakeLists.txt
@@ -1,5 +1,5 @@
PROJECT(SUBDIR)
-SUBDIRS("Executable Sources" EXCLUDE_FROM_ALL "Some Examples")
+SUBDIRS("Executable Sources" "Some(x86) Sources" EXCLUDE_FROM_ALL "Some Examples")
WRITE_FILE(${SUBDIR_BINARY_DIR}/ShouldBeHere "This file should exist.")
#WATCOM WMAKE does not support + in the name of a file!
IF(WATCOM)
@@ -41,3 +41,5 @@ ELSE(WATCOM)
vcl_algorithm+vcl_pair+double.foo.c)
ENDIF(WATCOM)
ADD_EXECUTABLE(TestWithAuxSourceDir ${SOURCES})
+target_link_libraries(TestWithAuxSourceDir testOddPath)
+