summaryrefslogtreecommitdiffstats
path: root/Tests/SystemInformation/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2003-03-17 13:25:45 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2003-03-17 13:25:45 (GMT)
commita2c4d8eb90efe6f8d343fc91b9ee1552c6890f14 (patch)
tree7e062ce4221e2a87b9663a2c62989ff64da2d52e /Tests/SystemInformation/CMakeLists.txt
parent4a2d04f42adc74c34cce19d2e24face723d9a469 (diff)
downloadCMake-a2c4d8eb90efe6f8d343fc91b9ee1552c6890f14.zip
CMake-a2c4d8eb90efe6f8d343fc91b9ee1552c6890f14.tar.gz
CMake-a2c4d8eb90efe6f8d343fc91b9ee1552c6890f14.tar.bz2
Display Cache and all variables
Diffstat (limited to 'Tests/SystemInformation/CMakeLists.txt')
-rw-r--r--Tests/SystemInformation/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/SystemInformation/CMakeLists.txt b/Tests/SystemInformation/CMakeLists.txt
index 7e67f56..8fbba95 100644
--- a/Tests/SystemInformation/CMakeLists.txt
+++ b/Tests/SystemInformation/CMakeLists.txt
@@ -6,8 +6,11 @@ CONFIGURE_FILE(${DumpInformation_SOURCE_DIR}/DumpInformation.h.in
${DumpInformation_BINARY_DIR}/DumpInformation.h)
ADD_EXECUTABLE(DumpInformation DumpInformation.cxx)
+WRITE_FILE(${DumpInformation_BINARY_DIR}/AllVariables.txt "")
GET_CMAKE_PROPERTY(VARS VARIABLES)
FOREACH(var ${VARS})
- MESSAGE(STATUS "Variable ${var} \"${${var}}\"")
+ WRITE_FILE(${DumpInformation_BINARY_DIR}/AllVariables.txt
+ "${var} \"${${var}}\"" APPEND)
+ #MESSAGE(STATUS "Variable ${var} \"${${var}}\"")
ENDFOREACH(var ${VARS})