summaryrefslogtreecommitdiffstats
path: root/Tests/TestsWorkingDirectory/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2011-01-20 18:47:53 (GMT)
committerBen Boeckel <ben.boeckel@kitware.com>2011-01-20 18:47:53 (GMT)
commit0594287606dad64904935901d5625b4f47d61ef6 (patch)
treea7d8ef426e945f1594052767790ef2a6f0bacbad /Tests/TestsWorkingDirectory/CMakeLists.txt
parent6529d7f67e05903ca29347c3220a0c91ce1f2905 (diff)
downloadCMake-0594287606dad64904935901d5625b4f47d61ef6.zip
CMake-0594287606dad64904935901d5625b4f47d61ef6.tar.gz
CMake-0594287606dad64904935901d5625b4f47d61ef6.tar.bz2
Add more tests for WorkingDirectory for tests
Diffstat (limited to 'Tests/TestsWorkingDirectory/CMakeLists.txt')
-rw-r--r--Tests/TestsWorkingDirectory/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/TestsWorkingDirectory/CMakeLists.txt b/Tests/TestsWorkingDirectory/CMakeLists.txt
index 0fef19d..a0fd18a 100644
--- a/Tests/TestsWorkingDirectory/CMakeLists.txt
+++ b/Tests/TestsWorkingDirectory/CMakeLists.txt
@@ -7,6 +7,8 @@ enable_testing()
set(EXECUTABLE_OUTPUT_PATH "${CMAKE_BINARY_DIR}/bin")
+add_test(NAME WorkingDirectory0 COMMAND WorkingDirectory "${CMAKE_BINARY_DIR}")
+
add_test(NAME WorkingDirectory1 COMMAND WorkingDirectory "${CMAKE_BINARY_DIR}")
set_tests_properties(WorkingDirectory1 PROPERTIES
WORKING_DIRECTORY "${CMAKE_BINARY_DIR}"
@@ -19,7 +21,7 @@ set_tests_properties(WorkingDirectory2 PROPERTIES
WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/.."
)
-get_filename_component(_default_cwd "${EXECUTABLE_OUTPUT_PATH}" PATH)
+set(_default_cwd "${CMAKE_BINARY_DIR}")
# FIXME: How to deal with /debug, /release, etc. with VS or XCode?
if(${CMAKE_GENERATOR} MATCHES "Makefiles")
@@ -36,3 +38,5 @@ add_test(NAME WorkingDirectory5 WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/.. COMMAND
if(${CMAKE_GENERATOR} MATCHES "Makefiles")
add_test(WorkingDirectory6 ${EXECUTABLE_OUTPUT_PATH}/WorkingDirectory ${_default_cwd} WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/..)
endif()
+
+add_subdirectory(subdir)