summaryrefslogtreecommitdiffstats
path: root/Tests/TryCompile/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-08-04 18:37:46 (GMT)
committerBrad King <brad.king@kitware.com>2009-08-04 18:37:46 (GMT)
commit80c947b3975825f2a9a7b1ebdc285e6b0cf6ba02 (patch)
tree85d047b0e5023e668a4804833198d4dcf767a539 /Tests/TryCompile/CMakeLists.txt
parentf3cd1e06f5a5fb092f249de3e1b582125d067daa (diff)
downloadCMake-80c947b3975825f2a9a7b1ebdc285e6b0cf6ba02.zip
CMake-80c947b3975825f2a9a7b1ebdc285e6b0cf6ba02.tar.gz
CMake-80c947b3975825f2a9a7b1ebdc285e6b0cf6ba02.tar.bz2
No /fast targets in try_compile project mode
The try_compile command builds the cmTryCompileExec executable using the cmTryCompileExec/fast target with Makefile generators in order to save time since dependencies are not needed. However, in project mode the command builds an entire source tree that may have dependencies. Therefore we can use the /fast target approach only in one-source mode.
Diffstat (limited to 'Tests/TryCompile/CMakeLists.txt')
-rw-r--r--Tests/TryCompile/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/Tests/TryCompile/CMakeLists.txt b/Tests/TryCompile/CMakeLists.txt
index 7895d39..5925a87 100644
--- a/Tests/TryCompile/CMakeLists.txt
+++ b/Tests/TryCompile/CMakeLists.txt
@@ -110,8 +110,9 @@ MESSAGE("Testing try_compile project mode")
TRY_COMPILE(TEST_INNER
${TryCompile_BINARY_DIR}/CMakeFiles/Inner
${TryCompile_SOURCE_DIR}/Inner
- TryCompileInner)
-TEST_ASSERT(TEST_INNER "try_compile project mode failed")
+ TryCompileInner innerexe
+ OUTPUT_VARIABLE output)
+TEST_ASSERT(TEST_INNER "try_compile project mode failed:\n${output}")
ADD_EXECUTABLE(TryCompile pass.c)