summaryrefslogtreecommitdiffstats
path: root/Tests/Tutorial/Step3/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2005-11-10 15:50:09 (GMT)
committerKen Martin <ken.martin@kitware.com>2005-11-10 15:50:09 (GMT)
commit814f0a573afba55840b5b3d7cdb4b710a996e100 (patch)
tree43df0b0cf0c4abbc791e048c82800c8fffb724f9 /Tests/Tutorial/Step3/CMakeLists.txt
parentaadec14903f6248c644023dfb39d68b90762b253 (diff)
downloadCMake-814f0a573afba55840b5b3d7cdb4b710a996e100.zip
CMake-814f0a573afba55840b5b3d7cdb4b710a996e100.tar.gz
CMake-814f0a573afba55840b5b3d7cdb4b710a996e100.tar.bz2
ENH: step 3
Diffstat (limited to 'Tests/Tutorial/Step3/CMakeLists.txt')
-rw-r--r--Tests/Tutorial/Step3/CMakeLists.txt66
1 files changed, 66 insertions, 0 deletions
diff --git a/Tests/Tutorial/Step3/CMakeLists.txt b/Tests/Tutorial/Step3/CMakeLists.txt
new file mode 100644
index 0000000..3562045
--- /dev/null
+++ b/Tests/Tutorial/Step3/CMakeLists.txt
@@ -0,0 +1,66 @@
+project (Tutorial)
+
+# The version number.
+set (Tutorial_VERSION_MAJOR 1)
+set (Tutorial_VERSION_MINOR 0)
+
+# configure a header file to pass some of the CMake settings
+# to the source code
+configure_file (
+ "${PROJECT_SOURCE_DIR}/TutorialConfig.h.in"
+ "${PROJECT_BINARY_DIR}/TutorialConfig.h"
+ )
+
+# should we use our own math functions
+option(USE_MYMATH "Use tutorial provided math implementation" ON)
+
+# add the binary tree to the search path for include files
+# so that we will find TutorialConfig.h
+include_directories ("${PROJECT_BINARY_DIR}")
+
+# add the MathFunctions library?
+if (USE_MYMATH)
+ include_directories ("${PROJECT_SOURCE_DIR}/MathFunctions")
+ add_subdirectory (MathFunctions)
+ set (EXTRA_LIBS ${EXTRA_LIBS} MathFunctions)
+endif (USE_MYMATH)
+
+# add the executable
+add_executable (Tutorial tutorial.cxx)
+target_link_libraries (Tutorial ${EXTRA_LIBS})
+
+# add the install targets
+install_targets (/bin Tutorial)
+install_files (/include FILES "${PROJECT_BINARY_DIR}/TutorialConfig.h")
+
+
+# enable testing
+enable_testing ()
+
+# does the application run
+add_test (TutorialRuns Tutorial 25)
+
+# does it sqrt of 25
+add_test (TutorialComp25 Tutorial 25)
+set_tests_properties (TutorialComp25
+ PROPERTIES PASS_REGULAR_EXPRESSION "25 is 5"
+ )
+
+# does it handle negative numbers
+add_test (TutorialNegative Tutorial -25)
+set_tests_properties (TutorialNegative
+ PROPERTIES PASS_REGULAR_EXPRESSION "-25 is 0"
+ )
+
+# does it handle small numbers
+add_test (TutorialSmall Tutorial 0.0001)
+set_tests_properties (TutorialSmall
+ PROPERTIES PASS_REGULAR_EXPRESSION "0.0001 is 0.01"
+ )
+
+# does the usage message work?
+add_test (TutorialUsage Tutorial)
+set_tests_properties (TutorialUsage
+ PROPERTIES
+ PASS_REGULAR_EXPRESSION "Usage:.*number"
+ )