summaryrefslogtreecommitdiffstats
path: root/Tests/UseSWIG/MultipleModules/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2019-05-04 15:09:31 (GMT)
committerMarc Chevrier <marc.chevrier@gmail.com>2019-05-07 14:37:24 (GMT)
commit30b873c05d6281b865ba08524bb1b90e0afd1ece (patch)
tree235ff9a85d3a4e83de7f2b7ad94037d1edcb07eb /Tests/UseSWIG/MultipleModules/CMakeLists.txt
parent37bf503db268c41d5a337265300357c76bda34ea (diff)
downloadCMake-30b873c05d6281b865ba08524bb1b90e0afd1ece.zip
CMake-30b873c05d6281b865ba08524bb1b90e0afd1ece.tar.gz
CMake-30b873c05d6281b865ba08524bb1b90e0afd1ece.tar.bz2
FindPython*: Manage weak link for Python modules
Add new target Python::Module which take care of platform requirements for Python module development. Fixes: #18100
Diffstat (limited to 'Tests/UseSWIG/MultipleModules/CMakeLists.txt')
-rw-r--r--Tests/UseSWIG/MultipleModules/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/UseSWIG/MultipleModules/CMakeLists.txt b/Tests/UseSWIG/MultipleModules/CMakeLists.txt
index f1dc379..4380080 100644
--- a/Tests/UseSWIG/MultipleModules/CMakeLists.txt
+++ b/Tests/UseSWIG/MultipleModules/CMakeLists.txt
@@ -36,7 +36,7 @@ set_target_properties (example1 PROPERTIES
LIBRARY_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/Python"
ARCHIVE_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/Python"
RUNTIME_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/Python")
-target_link_libraries(example1 PRIVATE Python::Python)
+target_link_libraries(example1 PRIVATE Python::Module)
# re-use sample interface file for another plugin
set_property(SOURCE "../example.i" APPEND PROPERTY